TYPO3-EXT-SA-2022-007: SQL Injection in extension "One is Enough Library" (oelib)

 

 

 

  • Release Date: April 26, 2022
  • Component Type: Third party extension. This extension is not a part of the TYPO3 default installation.
  • Component: "One is Enough Library" (oelib)
  • Vulnerability Type: SQL Injection
  • Affected Versions: 4.1.5 and below
  • Severity: Medium
  • Suggested CVSS: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:F/RL:O/RC:X
  • References: CVE-2022-29600

Problem Description

The extension fails to properly sanitize user input and is susceptible to SQL Injection.

Solution

An updated version 4.1.6  is available from the TYPO3 extension manager, packagist and at

https://extensions.typo3.org/extension/download/oelib/4.1.6/zip/

Users of the extension are advised to update the extension as soon as possible.

Credits

Thanks to Oliver Klee  for providing an updated version of the extension.

General Advice

Follow the recommendations that are given in the TYPO3 Security Guide. Please subscribe to the typo3-announce mailing list.