TYPO3-EXT-SA-2022-005: Remote Code Execution in extension "Job portal" (psvneo_jobfair)

 

 

 

  • Release Date: April 26, 2022
  • Component Type: Third party extension. This extension is not a part of the TYPO3 default installation.
  • Component: "Job portal" (psvneo_jobfair)
  • Vulnerability Type: Remote Code Execution
  • Affected Versions: 3.0.0 and below
  • Severity: Critical
  • Suggested CVSS: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:F/RL:O/RC:C
  • References: N/A

Problem Description

The extension fails to verify the filetype of uploaded files which allows an unauthenticated user to upload various PHP files to the web server resulting in Remote Code Execution.

Solution

An updated version 3.0.1  is available via composer only, since the extension has not been published on TER.

Users of the extension are advised to update the extension as soon as possible.

Credits

Thanks to Security Team Member Torben Hansen for reporting the issue and to Wolf Utz and Security Team Member Oliver Hader for providing an updated version of the extension.

General Advice

Follow the recommendations that are given in the TYPO3 Security Guide. Please subscribe to the typo3-announce mailing list.